We had a several-hour-long code-review-turned-meeting a few days ago. Generally these are accompanied by much groaning and frustration- but, this particular meeting was extremely productive. The discussion was over various UI technologies we're using, and what direction we wanted to head in.
This lead me to a thought today: although it seemed so simple at the time, giving unknown object / function / class library / thing an arbitrary name that we could refer to later in the discussion was a great move. It allowed us to move forward without getting lost in a long and tedious discussion on what to call it, because what was important was the idea of Steve, not the implementation. What could have been an additional hour added into the meeting was saved, thanks to Steve.